Username Search Not working in login Audit

Post Reply
hemantaseri
Posts: 1
Joined: Fri Feb 06, 2015 7:29 pm

Username Search Not working in login Audit

Post by hemantaseri » Fri Feb 06, 2015 7:44 pm

Hello,
I had installed the opacus login audit in Sugarcrm 6.5.20. It's showing results correctly but we faced an issue in that. Username Search field not working fine. It's not showing the correct results.
Ex:
I have a some results list in login audit.
http://prntscr.com/61vg6p

I am trying to search only test or admin status records in list. When i am selecting the name by field that time it display the typed name in username field.

1. When i was select the admin it's not showing any change in list.
http://prntscr.com/61vha9

2. When i am selecting the test username that time it's show blank list view.
http://prntscr.com/61vhte

Please URL and Attachment.

Please check this and guide me how can i solve this.

Thanks & Regards:
Hemant Aseri
Attachments
login au3.png
when username blank in list view search
login au3.png (27.64 KiB) Viewed 17960 times
login au2.png
when select username "Test" in list view search
login au2.png (16.61 KiB) Viewed 17960 times
login au1.png
when select username "admin" in list view search
login au1.png (27.34 KiB) Viewed 17960 times

jobst
Posts: 11
Joined: Mon Feb 06, 2012 1:05 am

Re: Username Search Not working in login Audit

Post by jobst » Wed Apr 29, 2015 7:15 am

Hi

that is because the assigned_user_id and modified_user_id are all set to "1" which is the (default) admin user in Sugar.

This limits the searches to ONLY find the admin user.

go to "YOUR_SUGAR_INSTANCE/modules/la_LoginAudit" and replace in the file "hook_functions.php" the last query with:

Code: Select all

 
$query = "INSERT INTO la_loginaudit (id,name,date_entered,date_modified,modified_user_id,created_by,description,deleted,assigned_user_id,ip_address,typed_name,is_admin,result) VALUES ('$uuid','',' $timestamp', '$timestamp','$current_user->id','$current_user->id','login',    '0',    '$current_user->id','$ip_address','$typed_name','$current_user->is_admin','$la_result')";
After you have done this your searches will return better results.
Maybe opacus should fix this?

Jobst

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest