[Workaround] Fix for 'error in deserializing body of reply'

Got a problem with the Opacus Professional SugarCRM Outlook Plugin ? Please post it here
User avatar
opacus.daniel
Site Admin
Posts: 500
Joined: Thu Feb 04, 2010 5:01 pm
Contact:

[Workaround] Fix for 'error in deserializing body of reply'

Post by opacus.daniel » Tue Sep 04, 2012 1:28 pm

After lots of head scratching we have finally found the problem. The issue is caused by the amount of data returned from the web service call.
In cases where there are lots of contacts that need syncing the returned data set exceeds the set boundaries.

To fix this please do the following...

1. Close Outlook
2. Navigate to the Opacus plugin install directory - C:/Program Files/Opacus Solutions/Opacus SugarCRM Plugin/ (this may be different depending on your environment)
3. Open "Opacus SugarCRM AddIn.dll.config" in a text editor
4. Locate line 19 and look for "maxStringContentLength property
5. Increase the number to something much larger (i added a few 1's to the front)
6. Save the file
7. Open Outlook
8. Clear your last sync time
9. Run a new Sync.

Let us know if this works for you. :)

We will be releasing a patch with a fix for this shortly.

markpickford
Posts: 56
Joined: Sat Feb 13, 2010 11:44 am

Re: [Workaround] Fix for 'error in deserializing body of reply'

Post by markpickford » Tue Sep 04, 2012 2:41 pm

Hi Daniel,

Is there are specific value that maxStringContentLength should be set to?

I have a version of Outlook 2007 running in Parallels on a Mac and in Windows 7 on a PC. I have added two 1's to the first instance (Parallels) and three 1's to the Windows instance. So far the sync is running, but nothing is transferring. The dialogue box is open, but the progress bar is empty.

It has been like this for the last 20+ minutes.

If I get an error I'll look at the log and let you know the contents.

Kind regards,

Mark

PS add too many 1's and the add-in will crash - I tried it with 10 and had to re-edit the number entered.

markpickford
Posts: 56
Joined: Sat Feb 13, 2010 11:44 am

Re: [Workaround] Fix for 'error in deserializing body of reply'

Post by markpickford » Tue Sep 04, 2012 3:07 pm

Hi Daniel.

I gave up after 30 minutes of no sync activity.

What I have tried to do was:

- sync contacts (limit set to 10 so no memory issues interfere with the process)
- sync appointments (limit set to 10 again)

In both of the above nothing happened.

On a slightly different note have a look at the New Record button in the add-in. There is no Task option. I don't know if this is intended or an oversight, but I thought I would let you know.

Kind regards,

Mark

markpickford
Posts: 56
Joined: Sat Feb 13, 2010 11:44 am

Re: [Workaround] Fix for 'error in deserializing body of reply'

Post by markpickford » Tue Sep 04, 2012 3:27 pm

Hi Daniel,

Success.

Close Outlook, set the value in the file you describe to 1116384, save, open Outlook, reset the sync time as described (you may get 'Unable to Authenticate' error at this stage and if you do click the restore settings button and follow the above from and including the open Outlook step) and then sync.

So far all appointments, contacts and tasks have transferred perfectly and sync far quicker than the old version of the plug-in.

Thanks for your help sorting this out.

Kind regards,

Mark

markpickford
Posts: 56
Joined: Sat Feb 13, 2010 11:44 am

Re: [Workaround] Fix for 'error in deserializing body of reply'

Post by markpickford » Mon Sep 17, 2012 12:15 pm

Hi Daniel,

I forgot to mention that in order for the above to work all data (contacts, appointments, tasks etc.) had to be deleted from Outlook before syncing would work.

If data wasn't deleted then no sync would take place and all that would happen is that the progress bar would show, with nothing happening.

I have done this on three different computers now and as a consequence I am fairly sure this is a part of the fix that needs to be done in order to make it work.

I will try it on a fourth computer this afternoon and will post again if there is any variance.

Mark

nigelclarke
Posts: 1
Joined: Tue Sep 18, 2012 4:01 pm
Location: Birmingham, UK
Contact:

Re: [Workaround] Fix for 'error in deserializing body of reply'

Post by nigelclarke » Tue Sep 18, 2012 4:06 pm

Hi, I'm a new user and seem to be experiencing the same issue described here. I have not previously successfully synced Sugar with Outlook.
I tried syncing via add-ins > sync > appointments and the progress bar appeared but made no progress. I tried editing the file as described and added three 1s to the number, cleared the last sync time and tried again, again nothing happening.
In the last post you mention deleting all data from Outlook, do you mean literally everything, all contacts etc, as I have data in Outlook which does not sync with Sugar, so if I delete it, it's gone... I may be missing something here, any help/advice is much appreciated as I would love to get this working!

markpickford
Posts: 56
Joined: Sat Feb 13, 2010 11:44 am

Re: [Workaround] Fix for 'error in deserializing body of reply'

Post by markpickford » Wed Sep 19, 2012 8:32 am

Hi Nigel,

I experienced exactly the same things you describe and found that deleting all Outlook data (export all the data first so you have a copy in case this doesn't work for you) and changing the value in the Add-in Config file to 1116384 worked for me.

I updated one of our computers yesterday and to check if what I have found was accurate I tried the fix that was posted first. Nothing happened. The progress bar was active, but no sync took place.

Next, I altered the config file value as described above, deleted all Outlook data (after backing up), installed the new version of the add-in, re-set the sync time and closed Outlook. When I opened Outlook again and performed a sync all data was transferred from Sugar to Outlook.

With regard to your data that is not syncing to Sugar, I am unable to offer any advice here. Perhaps you could transfer it to a new calendar (if the data are appointments), task list and contact book and then export that data under a different file name.

I hope this helps.

Kind regards,

Mark

venicegal
Posts: 3
Joined: Sat Nov 24, 2012 4:11 pm

Re: [Workaround] Fix for 'error in deserializing body of reply'

Post by venicegal » Wed Nov 28, 2012 10:30 pm

I'm an admin, not an IT person, so you'll have to forgive me.

I follow the directions but when I go to save, it saves as a txt file and not a DLL file. How do I remedy this?

User avatar
opacus.daniel
Site Admin
Posts: 500
Joined: Thu Feb 04, 2010 5:01 pm
Contact:

Re: [Workaround] Fix for 'error in deserializing body of reply'

Post by opacus.daniel » Thu Nov 29, 2012 8:47 am

Hi,

The file should be a ".config" file, it is the config file for the DLL rather than the DLL itself. You probably have the "hide common file extensions" turned on in your windows explorer settings so it appears as ".dll" but its actually ".dll.config". If you saved the file you opened it should of overwritten the correct file.

paulsherwin
Posts: 4
Joined: Mon May 20, 2013 7:36 am

Re: [Workaround] Fix for 'error in deserializing body of rep

Post by paulsherwin » Mon May 20, 2013 7:45 am

I continue to get this problem with the following error message:
2013-05-20 08:34:33,639 [10] FATAL OutlookAddIn.OSOP [(null)] – Error in deserializing body of reply message for operation 'sync_get_modified_relationships'.
2013-05-20 08:34:33,640 [10] FATAL OutlookAddIn.OSOP [(null)] – Fatal sync error:Object reference not set to an instance of an object. at OutlookAddIn.SyncController.SynchroniseAppointments()
2013-05-20 08:34:33,658 [10] ERROR OutlookAddIn.OSOP [(null)] – There was an error with the sync process, please see the log for more information

I am using v2.2.0.1 Pro on a trial version. I have tried the fix stated in previous posts but cannot get access to the file stated as it comes up with "access denied" I only have a few days left on the trial.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests